Jump to content
FLProg.PRO

SIM 800L не отвечает на команды в адресной строке


Itat
 Share

Recommended Posts

Здравствуйте, уважаемые форумчане! Как всегда обращаюсь за помощью. 

Проблема следующая: присоединил SIM800L к  Arduino UNO, в мониторе порта отображается Start !  , а на другие команды (например, АТ) нет никакой реакции.

Схему питания SIM800L организовал через отдельный блок питания, подавая 4 В. Прикрепляю скриншоты

Питание.bmp

Питание.bmp

Скриншот проги.bmp

Link to comment
Share on other sites

Попытался изменить бод (перепробовал от 300 до 115200), каждый раз перекомпилируя программу. В монитор порта выводится Start. При некоторых бод на АТ-команду выводятся вопросительные знаки или квадратики. 

Попытки бод.bmp

Кстати, на модуле SIM800L не вижу, чтобы какой-либо светодиод мигал или светился 

Link to comment
Share on other sites

Ура! Всё (ну, или почти всё) заработало!!! Нашел причину.Низкое напряжение подавалось на SIM800L, вот, какая причина была. У меня синий модуль.  В общем 4 В не хватает для работы этому модулю, стал работать при 5,1В. Для синего модуля никакой делитель напряжения не нужен. В нём уже всё есть. Запитал от одного блока питания и Ардуинку и GSMмодуль, чтобы массы были общие

Теперь буду тестировать всеми AT-командами и усядусь поподробнее изучать пользовательский блок в FLProg (спасибо автору блока!)

Пользовался хорошей информацией отсюда https://habr.com/ru/articles/657935/

  • Haha 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...